npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community. - Unexpected token u in JSON at position 0

What I Wanted to Do

View the rollup-stream (among several others) package in chrome (tested in other browsers, same result)

What Happened Instead

I get the following where the package info normally is

### Unexpected token u in JSON at position 0

id:  `wubwub-7-west:2a884a2f-acf5-42ce-8d77-2b761bbf26a2`

Reproduction Steps

Visit rollup-stream in your browser


Request Headers

:method: GET
:path: /package/rollup-stream
:scheme: https
accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
accept-encoding: gzip, deflate, br
accept-language: en-GB,en-US;q=0.9,en;q=0.8
cache-control: max-age=0
cookie: __cfduid=d57b1bf481ad47fa994893970e66c15391533725253
upgrade-insecure-requests: 1
user-agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36

Response Headers

cache-control: public, max-age=14400
cf-cache-status: HIT
cf-ray: 447186eb4fc03665-MAN
content-encoding: br
content-type: text/html
date: Wed, 08 Aug 2018 11:08:47 GMT
expect-ct: max-age=604800, report-uri=""
expires: Wed, 08 Aug 2018 15:08:47 GMT
npm-cost: 1
npm-remaining: 99
server: cloudflare
status: 200
strict-transport-security: max-age=31536000
vary: x-requested-with, x-spiferack, Accept-Encoding
x-clacks-overhead: terry pratchett
x-content-type-options: nosniff
x-frame-options: DENY
x-xss-protection: 1; mode=block


I get the same error as well.

id: `wubwub-8-west:1f95ecae-448a-470f-ac78-7d5a1cdea3b9`

I also tested this in firefox and chrome, so did my colleague.

I visited this page and several others.
The issue remains the same.



Unexpected token u in JSON at position 0
id: wubwub-7-west:a27cb72b-50fd-4be9-837e-63f91162c779

Happens to me as well. On all packages. Tested on Chrome, Chrome(Incognito), Chrome Canary and Edge.

I get the same error for cache-flex and http-errors-promise

Guys. This doesnโ€™t just happen with a package here and there, it happens with every package.


Yup, works again for me.

Not worked for me (trying to view express-recaptcha module):

Unexpected token u in JSON at position 0

id: wubwub-9-west:e10f449f-fa45-4958-a13f-518d27cb51b2

duplicate of Cannot access any page from npm