Windows 8.1 SDK not detected.


(Mark Skits) #1

I have no idea why this error comes up when i install chartjs-node. I made sure to install the sdk, as well as executing “npm i windows-build-tools --production --vs2015 --add-python-to-PATH --global” as Adminstrator and restarted afterwards.

C:\Users\Mark\Desktop\Stock Bot>npm install chartjs-node

> canvas@1.6.13 install C:\Users\Mark\Desktop\Stock Bot\node_modules\canvas
> node-gyp rebuild


C:\Users\Mark\Desktop\Stock Bot\node_modules\canvas>if not defined npm_config_node_gyp (node 
"D:\Node\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\\..\..\node_modules\node- 
gyp\bin\node-gyp.js" rebuild )  else (node "D:\Node\node_modules\npm\node_modules\node-gyp\bin\node- 
gyp.js" rebuild )
Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch.
C:\Program Files 
(x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error
 MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or 
change the SDK vers
ion in the project property pages or by right-clicking the solution and selecting "Retarget solution". 
[C:\Users\Mark\Desktop\Stock Bot\node_modules\canvas\build\canvas.vcxproj]
gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (D:\Node\node_modules\npm\node_modules\node- 
gyp\lib\build.js:258:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:225:12)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "D:\\Node\\node.exe" "D:\\Node\\node_modules\\npm\\node_modules\\node- 
gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\Mark\Desktop\Stock Bot\node_modules\canvas
gyp ERR! node -v v10.0.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
npm WARN discord.js@11.4.2 requires a peer of bufferutil@^3.0.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of erlpack@discordapp/erlpack but none is installed. You 
must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of node-opus@^0.2.7 but none is installed. You must install 

peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of opusscript@^0.0.6 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of sodium@^2.0.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of libsodium-wrappers@^0.7.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of uws@^9.14.0 but none is installed. You must install peer dependencies yourself.
npm WARN Stock Bot license should be a valid SPDX license expression

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! canvas@1.6.13 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the canvas@1.6.13 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Mark\AppData\Roaming\npm-cache\_logs\2019-01-12T21_16_14_921Z-debug.log

(system) #2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.