npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

when I use `npm outdated --long` , I get error

What I Wanted to Do

when I run npm outdated --long , I get error

Reproduction Steps

run npm outdated --long

Details

image

Platform Info

$ npm --versions
npm 6.5.0
$ node -p process.platform
darwin

Reason

The error because npm depending on text-table and my npm package don’t have homepage property.
when I run npm outdated --long, the homepage get undefined. If use text-table show info, it will throw error.
text-table have bug.

You can get more info in https://github.com/substack/text-table/pull/17

I create a pull request to text-table.

please keep a watchful eye on latest verison of text-table. Finally, fix the bug.


Should be fixed in v6.6.0 (see PR).


I get the same error if i do a npm outdated -g
is it fixed for the --long?

> npm --version
6.9.0
> node -p process.platform
win32


That’s a different issue, should be fixed in v6.9.1 (can be checked with v6.9.1-next.0, see PR).