vulnerabilyt fix required npm@6.10.0 dependency @ tar package

Package: tar
current npm@6.10.0 installed tar version: 2.2.2
Fix Version: 4.4.2 (Upgrade package tar to version 4.4.2or above.)
Description:
Versions of node-tar prior to 4.4.2 are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink will overwrite the system’s file with the contents of the extracted file.
image

Reference Link:https://github.com/npm/node-tar/commit/b0c58433c22f5e7fe8b1c76373f27e3f81dcd4c8