Update a dependency of the npm module

Hello,

I am currently using node v10.16.0 (npm v6.9.0).
When trying to npm install the project it fails from the pacote@9.5.0 dependency of npm with a:
TypeError: err.code.match is not a function
which is actually already fixed in https://github.com/zkat/pacote/commit/92f5e4c as explained in the changelog here https://github.com/zkat/pacote/commit/3b9e844231857b705b3c421ff761757a77fc37a5

It’s not clear to me how to proceed with signifying that npm should use the 9.5.1 version, instead of 9.5.0.

Thank you in advance!

Hi Chris! Are you asking as a developer cloning the npm cli code and wanting to update the pacote dependency and possibly submit a Pull Request, or hack your npm install? Or as an ordinary user of npm?

If you are asking as an ordinary user, we wait for a release of npm with the newer version of pacote. And that is an unknown wait, with last release still in limbo:

(Thanks for the useful pacote links.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.