Unknown system error -122

What I Wanted to Do

Run: “npm config set prefix ‘~/.npm-global’”

What Happened Instead

npm ERR! Linux 2.6.32-696.18.7.el6.x86_64
npm ERR! argv "/auto/sw/packages/node/v4.2.6/bin/node" "/router/bin/npm" "config" "set" "prefix" "/auto/srg-sce-swinfra-usr/emb/users/myuser/work/npm-global/"
npm ERR! node v4.2.6
npm ERR! npm  v2.14.12
npm ERR! code Unknown system error -122
npm ERR! errno -122
npm ERR! syscall close

npm ERR! Unknown system error -122: Unknown system error -122, close
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /scratch/myuser/p4/depot/asr1k/emb/integration/scripts/42ool/42ool/npm-debug.log

Reproduction Steps

Run npm config set prefix ‘~/.npm-global’

Details

0 info it worked if it ends with ok
1 verbose cli [ '/auto/sw/packages/node/v4.2.6/bin/node',
1 verbose cli   '/router/bin/npm',
1 verbose cli   'config',
1 verbose cli   'set',
1 verbose cli   'prefix',
1 verbose cli   '/auto/srg-sce-swinfra-usr/emb/users/myuser/work/npm-global/' ]
2 info using npm@2.14.12
3 info using node@v4.2.6
4 info config set "prefix" "/auto/infra/emb/users/myuser/work/npm-global/"
5 verbose stack Error: Unknown system error -122: Unknown system error -122, close
5 verbose stack     at Error (native)
6 verbose cwd /scratch/myuser/p4/depot/asr1k/emb/integration/scripts/42ool/42ool
7 error Linux 2.6.32-696.18.7.el6.x86_64
8 error argv "/auto/sw/packages/node/v4.2.6/bin/node" "/router/bin/npm" "config" "set" "prefix" "/auto/srg-sce-swinfra-usr/emb/users/myuser/work/npm-global/"
9 error node v4.2.6
10 error npm  v2.14.12
11 error code Unknown system error -122
12 error errno -122
13 error syscall close
14 error Unknown system error -122: Unknown system error -122, close
15 error If you need help, you may report this error at:
15 error     <https://github.com/npm/npm/issues>
16 verbose exit [ -122, true ]

Platform Info

Linux csi-sceasr-b90 2.6.32-696.18.7.el6.x86_64 #1 SMP Thu Dec 28 20:15:47 EST 2017 x86_64 x86_64 x86_64 GNU/Linux

$ npm --versions
2.4.12
$ node -p process.platform
node v4.2.6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.