Unable to use "npm outdated -g"

What I Wanted to Do

npm outdated -g

What Happened Instead

npm outdated -g

npm ERR! Cannot read property ‘length’ of undefined

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\doberkofler.LBITS\AppData\Roaming\npm-cache_logs\2019-03-17T12_23_39_415Z-debug.log

C:\Users\doberkofler.LBITS\AppData\Roaming\npm-cache_logs\2019-03-17T12_23_39_415Z-debug.log:

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Users\\doberkofler.LBITS\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'outdated',
1 verbose cli   '-g' ]
2 info using npm@6.9.0
3 info using node@v10.15.3
4 verbose npm-session 0232eac124df3d6f
5 http fetch GET 304 https://registry.npmjs.org/undefined 234ms (from cache)
6 silly pacote registry packument for LEADINGJob@null fetched in 252ms
7 http fetch GET 304 https://registry.npmjs.org/npx 231ms (from cache)
8 silly pacote registry packument for npx@^10.2.0 fetched in 253ms
9 http fetch GET 304 https://registry.npmjs.org/yarn 234ms (from cache)
10 silly pacote registry packument for yarn@^1.13.0 fetched in 256ms
11 http fetch GET 304 https://registry.npmjs.org/npm 249ms (from cache)
12 silly pacote registry packument for npm@^6.9.0 fetched in 286ms
13 verbose stack TypeError: Cannot read property 'length' of undefined
13 verbose stack     at dotindex (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:59:32)
13 verbose stack     at C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:11:21
13 verbose stack     at Array.forEach (<anonymous>)
13 verbose stack     at forEach (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:73:31)
13 verbose stack     at C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:10:9
13 verbose stack     at Array.reduce (<anonymous>)
13 verbose stack     at reduce (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:63:30)
13 verbose stack     at module.exports (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:9:20)
13 verbose stack     at C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\lib\outdated.js:130:16
13 verbose stack     at cb (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\slide\lib\async-map.js:47:24)
13 verbose stack     at outdated_ (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\lib\outdated.js:221:12)
13 verbose stack     at skip (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\lib\outdated.js:343:5)
13 verbose stack     at updateDeps (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\lib\outdated.js:446:7)
13 verbose stack     at tryCatcher (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\bluebird\js\release\util.js:16:23)
13 verbose stack     at Promise.successAdapter [as _fulfillmentHandler0] (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\bluebird\js\release\nodeify.js:23:30)
13 verbose stack     at Promise._settlePromise (C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\bluebird\js\release\promise.js:566:21)
14 verbose cwd D:\MyDev\ljs_app\trunk\periscope
15 verbose Windows_NT 6.1.7601
16 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\doberkofler.LBITS\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "outdated" "-g"
17 verbose node v10.15.3
18 verbose npm  v6.9.0
19 error Cannot read property 'length' of undefined
20 verbose exit [ 1, true ]

C:\Users\doberkofler.LBITS\AppData\Roaming\npm\node_modules\npm\node_modules\text-table\index.js:59:32:

...
function dotindex (c) {
    var m = /\.[^.]*$/.exec(c);
    return m ? m.index + 1 : c.length; // <<< 59:32
}
...

Reproduction Steps

npm outdated -g

Details

Platform Info

$ npm --versions
{ periscope: '1.0.0',
  npm: '6.9.0',
  ares: '1.15.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.15.3',
  openssl: '1.1.0j',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '6.8.275.32-node.51',
  zlib: '1.2.11' }
$ node -p process.platform
win32

Duplicate of