Unable to install newly published package version


(Brent Vatne) #1

I published react-navigation-tabs@0.8.4 and went to install it and was unable to with either yarn or npm (6.4.1). I confirmed on the package page that it was published successfully. It has now been about 20 minutes since I published 0.8.4, and about 30 since I published 0.8.3, neither of them are available.

(Lars Willighagen) #2

The version seems to be available when I look it up in the registry by hand, but it seems pacote keeps fetching from cache:

7 http fetch GET 200 https://registry.npmjs.org/react-navigation-tabs 14ms (from cache)
8 silly registry:manifest no matching version for react-navigation-tabs@0.8.4 in the cache. Forcing revalidation
9 http fetch GET 304 https://registry.npmjs.org/react-navigation-tabs 104ms (from cache)
10 silly fetchPackageMetaData error for react-navigation-tabs@0.8.4 No matching version found for react-navigation-tabs@0.8.4

Not sure what’s happening there exactly, but while testing it started working already.

(Brent Vatne) #3

Thanks for the response @larsgw! It’s still not working on my end.

(Lars Willighagen) #4

That’s weird :confused:. Probably just some caching, but still… weird. And annoying. If you visit the registry entry in the browser do you see 0.8.4 already? Because I did, before the CLI started working on my end.

(Brent Vatne) #5

strange, I’m still seeing 0.8.2 as the latest in the browser

(Brent Vatne) #6

I also tried it from my phone and see 0.8.2 there as well. A colleague in another country entirely sees 0.8.2 too.

(Lars Willighagen) #7

When I view it with a VPN (Canada) I do see 0.8.2, so it seems like a regional caching thing. However, I’m not on the npm team so this is out of my control.

(Brent Vatne) #8

it seems to have resolved itself now

(Kat Marchán) #9

This is due to a temporary caching issue on the registry side. It has since been resolved and the original cause is being investigated more thoroughly.

(Aymeric) #10

Hi. It looks like the problem is back… I’ve just published v2.1.3 of a package, it appears on the website and with npm view, but it’s impossible to install. Same issue as @brentvatne

(Christopher) #11

I can also confirm the issue is back.

(André Hänsel) #13

I’m also experiencing this issue.

vue@2.5.22 has been released about 1 hour ago.

When I go to https://registry.npmjs.org/vue I can see version 2.5.22.

My npm on the other hand cannot find this version, apparently because it is using a cached version of that page:

283 silly install loadCurrentTree
284 silly install readLocalPackageData
285 http fetch GET 200 https://registry.npmjs.org/vue-template-compiler 15ms (from cache)
286 silly pacote version manifest for vue-template-compiler@2.5.22 fetched in 18ms
287 http fetch GET 200 https://registry.npmjs.org/vue 27ms (from cache)
288 silly registry:manifest no matching version for vue@2.5.22 in the cache. Forcing revalidation
289 http fetch GET 304 https://registry.npmjs.org/vue 122ms (from cache)
290 silly fetchPackageMetaData error for vue@2.5.22 No matching version found for vue@2.5.22
291 timing stage:rollbackFailedOptional Completed in 1ms
292 timing stage:runTopLevelLifecycles Completed in 1708ms
293 verbose type version
294 verbose stack vue: No matching version found for vue@2.5.22

I would actually be happy if it would just use a cached but consistent set of packages, but apparently npm got the information from somewhere that 2.5.22 is available and now it is trying to install it (and fails) and it won’t settle for 2.5.21.

(André Hänsel) #15

This problem went away when I upgraded npm from 6.4.1 to 6.7.0.

(Brent Vatne) #16

happening again for me, this time with expo-font@2.1.0-alpha.1

edit: seems to have resolved itself after a few minutes