Trying to install packeges


(Pudim Kbm) #1

What I Wanted to Do

I’m trying to install packages but it keeps shooting this error

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘install’, ‘npm@latest’ ]
2 info using npm@5.5.1
3 info using node@v8.11.2
4 verbose config Skipping project config: /home/pudimkbm/.npmrc. (matches userconfig)
5 verbose npm-session aaa619f9e0f3d254
6 silly install loadCurrentTree
7 silly install readLocalPackageData
8 silly fetchPackageMetaData error for npm@latest request to http://registry.npmjs.org/npm failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org:80
9 verbose type system
10 verbose stack FetchError: request to http://registry.npmjs.org/npm failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org:80
10 verbose stack at ClientRequest.req.on.err (/usr/lib/node_modules/npm/node_modules/pacote/node_modules/make-fetch-happen/node_modules/node-fetch-npm/src/index.js:68:14)
10 verbose stack at emitOne (events.js:116:13)
10 verbose stack at ClientRequest.emit (events.js:211:7)
10 verbose stack at Socket.socketErrorListener (_http_client.js:387:9)
10 verbose stack at emitOne (events.js:116:13)
10 verbose stack at Socket.emit (events.js:211:7)
10 verbose stack at emitErrorNT (internal/streams/destroy.js:64:8)
10 verbose stack at _combinedTickCallback (internal/process/next_tick.js:138:11)
10 verbose stack at process._tickCallback (internal/process/next_tick.js:180:9)
11 verbose cwd /home/pudimkbm
12 verbose Linux 4.15.0-29deepin-generic
13 verbose argv “/usr/bin/node” “/usr/bin/npm” “install” “npm@latest”
14 verbose node v8.11.2
15 verbose npm v5.5.1
16 error code EAI_AGAIN
17 error errno EAI_AGAIN
18 error request to “http://registry.npmjs.org/npm” failed, reason: getaddrinfo EAI_AGAIN registry.npmjs. org:80
19 verbose exit [ 1, true ]

Platform Info

Deeping 15.9.2 (linux)

$ npm --versions
5.5.1
$ node -p process.platform
v8.11.2

(John Gee) #2

I am not confident this is the issue, but are you behind a proxy? Common proxy and networking problems

(The EAI_AGAIN is a dns lookup failure.)