tink: Implement ancillary subcommands

help-wanted
good-first-patch
tink

(Alejandro López) #61

Hello @zkat

Here is the tink profile PR :slight_smile:


(Beni Von Cheni) #62

Good evening, @zkat. Per tink access, thanks for merging #12. I reviewed the code more & did a follow-up PR (#34) to improve a few things. Please review at convenience. :v:


(Beni Von Cheni) #63

Hi @zkat. Had this observation with the latest branch. When testing tink command(s) (e.g. tink build), I ran into the following error.

→ tink build
/Users/bchen/github/tink/bin/tink.js:49
    process.tink.config = yargv
                        ^

TypeError: Cannot set property 'config' of undefined
    at runCommandWithYargs (/Users/bchen/github/tink/bin/tink.js:49:25)
    at main (/Users/bchen/github/tink/bin/tink.js:30:10)
    at Object.<anonymous> (/Users/bchen/github/tink/bin/tink.js:22:3)
    at Module._compile (internal/modules/cjs/loader.js:722:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:733:10)
    at Module.load (internal/modules/cjs/loader.js:620:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:560:12)
    at Function.Module._load (internal/modules/cjs/loader.js:552:3)
    at Function.Module.runMain (internal/modules/cjs/loader.js:775:12)
    at startup (internal/bootstrap/node.js:300:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:826:3)

After debugging, I could simply comment out process.tink.config = yargv in tink/bin/tink.js:49, and tink command(s) worked again. Thought I’d post this comment to confirm. Thanks!


(Kat Marchán) #64

Yeah I was messing around with things and broke everything. It’ll be back in order soon. Do temp patches as needed for now.

Update: Should be fixed now, I think.