"This package contains unacceptable content." when publishing a scoped package

Problem

I can’t publish a package under an org (@bundl/) but I can do it without scope, e.g. npm publish works fine if I create a package and publish like usual.

Error output

➜ npm publish --access public
npm notice 
npm notice 📦  @bundl/buble@0.0.1
npm notice === Tarball Contents === 
npm notice 144B index.js    
npm notice 350B package.json
npm notice 359B README.md   
npm notice === Tarball Details === 
npm notice name:          @bundl/buble                            
npm notice version:       0.0.1                                   
npm notice package size:  597 B                                   
npm notice unpacked size: 853 B                                   
npm notice shasum:        c3fa20d6bb7fa22a73cbf399bbe7ee7360c817c0
npm notice integrity:     sha512-1IuCbqP9Lw7xx[...]W32uHepX6/tug==
npm notice total files:   3                                       
npm notice 
npm ERR! code E400
npm ERR! 400 Bad Request - PUT https://registry.npmjs.org/@bundl%2fbuble - This package contains unacceptable content. Contact support@npmjs.com.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/v1rtl/.npm/_logs/2019-08-07T16_41_04_653Z-debug.log

Log looks like this:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'publish', '--access', 'public' ]
2 info using npm@6.10.0
3 info using node@v12.7.0
4 verbose npm-session 516f0cca30f873f2
5 verbose publish [ '.' ]
6 info lifecycle @bundl/buble@0.0.1~prepublish: @bundl/buble@0.0.1
7 info lifecycle @bundl/buble@0.0.1~prepare: @bundl/buble@0.0.1
8 info lifecycle @bundl/buble@0.0.1~prepublishOnly: @bundl/buble@0.0.1
9 info lifecycle @bundl/buble@0.0.1~prepack: @bundl/buble@0.0.1
10 info lifecycle @bundl/buble@0.0.1~postpack: @bundl/buble@0.0.1
11 notice
12 notice 📦  @bundl/buble@0.0.1
13 notice === Tarball Contents ===
14 notice 144B index.js
14 notice 350B package.json
14 notice 359B README.md
15 notice === Tarball Details ===
16 notice name:          @bundl/buble
16 notice version:       0.0.1
16 notice package size:  597 B
16 notice unpacked size: 853 B
16 notice shasum:        c3fa20d6bb7fa22a73cbf399bbe7ee7360c817c0
16 notice integrity:     sha512-1IuCbqP9Lw7xx[...]W32uHepX6/tug==
16 notice total files:   3
17 notice
18 http fetch PUT 400 https://registry.npmjs.org/@bundl%2fbuble 1875ms
19 verbose stack Error: 400 Bad Request - PUT https://registry.npmjs.org/@bundl%2fbuble - This package contains unacceptable content. Contact support@npmjs.com.
19 verbose stack     at /usr/lib/node_modules/npm/node_modules/npm-registry-fetch/check-response.js:104:15
19 verbose stack     at processTicksAndRejections (internal/process/task_queues.js:85:5)
20 verbose statusCode 400
21 verbose pkgid @bundl/buble@0.0.1
22 verbose cwd /home/v1rtl/Desktop/Coding/bundl-plugins/buble
23 verbose Linux 5.0.0-23-generic
24 verbose argv "/usr/bin/node" "/usr/bin/npm" "publish" "--access" "public"
25 verbose node v12.7.0
26 verbose npm  v6.10.0
27 error code E400
28 error 400 Bad Request - PUT https://registry.npmjs.org/@bundl%2fbuble - This package contains unacceptable content. Contact support@npmjs.com.
29 verbose exit [ 1, true ]

Platform Info

Ubuntu 18.04

{
  '@bundl/buble': '0.0.1',
  npm: '6.10.0',
  ares: '1.15.0',
  brotli: '1.0.7',
  cldr: '35.1',
  http_parser: '2.8.0',
  icu: '64.2',
  llhttp: '1.1.4',
  modules: '72',
  napi: '4',
  nghttp2: '1.39.1',
  node: '12.7.0',
  openssl: '1.1.1c',
  tz: '2019a',
  unicode: '12.1',
  uv: '1.30.1',
  v8: '7.5.288.22-node.16',
  zlib: '1.2.11'
}

Have you contacted support, as per the message?

Previous similar postings have not seen much follow-up in forum:

They didn’t respond yet but today package publishing works! I don’t know what happened.

1 Like

The automatic blocks do get reviewed by a human because they’re often a spammer or troll that needs their account and/or IP address blocked. When there are false positives, we revise the rules. That could be what happened in this case. Contacting support is a good step to make sure, though.

Thanks for update @talentlessguy, and for info @isaacs. That confirms the stories that it does sometimes just start working a few days later. :-)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.