npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

The warning appears whenever npm install

31%20PM


51%20PM


The short version is install the package it asks for.

The package you are installing requires or expects another package, but for some reason it is not appropriate for it to specify it as a dependency. Instead it specifies it is a peerDependency
and npm warns you it is missing: https://nodejs.org/en/blog/npm/peer-dependencies/


Thank you for your answer!
I understand the cause of the problem.
27%20AM