npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

The `npm owner add` command is not doing anything

What I Wanted to Do

Add an owner to a package, either through or through the npm owner add <user> command.

What Happened Instead

Ownership did not take effect. Ownership is shown in correctly, but npm owner ls does not list the new owner. Intended new owner gets a 403 when trying to publish as well. npm whoami for both of us confirms we are logged in properly.

Reproduction Steps

For the package eslint-config-godaddy-react:

$ npm whoami

$ npm owner ls
gergelyke <>
indexzero <>
josephjnk <>
jpage <>
samshull <>

$ npm owner add sivanmehta
+ sivanmehta (eslint-config-godaddy-react)

$ npm owner ls
gergelyke <>
indexzero <>
josephjnk <>
jpage <>
samshull <>

Platform Info

$ npm --versions
{ 'eslint-config-godaddy-react': '3.0.0',
  npm: '6.7.0',
  ares: '1.15.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.15.0',
  openssl: '1.1.0j',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '',
  zlib: '1.2.11' }

$ node -p process.platform

…and now publish worked for them, although npm owner ls still doesn’t list them.

Is this a cache propagation issue? If so, is this behavior expected? If so, could that be documented somewhere so we know how long we should expect to wait for ownership to take effect?