I don’t think this is possible currently, but I think this would be useful to specify different versions of engines.node for project contributors (ie, installing/running the devtools) and the project consumers which only consume the built JS.
Take for example React-native (see issue)
- It requires node ^8.10.0 || >=9.10.0 for contributors (for running ESLint 5 which requires these minimum versions)
- It requires node >= 8.3 for consumers (for running ReactNative consumer tooling, like the cli, packager etc…)
As far as I know there is no way to declare that granularity in package.json and I think it could be helpful