[solved] npm ERR! invalid base256 encoding [angular]

Hi everybody !
I’m looking for help.

i’m trying to create a new angular project but i have a npm error.
i have install the latest version of npm and when i try to create a new angular project i get the following message :

npm WARN tar invalid entry
npm WARN tar invalid entry
npm WARN tar invalid entry
npm WARN tar invalid entry
npm ERR! invalid base256 encoding

is anyone has an idea about my problem ?

thank you

Are you behind a company proxy server?

I found a report with similar tar errors which were fixed by getting proxy working then clearing cache: https://stackoverflow.com/questions/47714946/angular-cli-installation-fails-at-step-fetchmetadata-sill-resolvewithnewmodule?rq=1

What command are you running that raises this error?

Can you share the npm-debug.log file that’s generated?

Hi , i think i found the solution and the problem.

Solution : i have uninstalled angular/cli, npm and node.js then i’ve reinstalled the 3.
Now, i can create angular project without error.

Problem: node.js, npm, angular/cli were previously installed on a HDD. This week , i changed my HDD for a SDD where i’ve cloned my old HDD. So i didn’t reinstall everything. I strongly think it was the reason of the error.

But thank you for your support !

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.