run nmp dev don't work


(yokaso) #1

Hi,i just installer server lite and when i want run the command run npm dev i got errors and don’t work with me ,i tried to fellow the setup instruction and add “dev”:“lite-serer” in package file.
my log:
0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘run’,
1 verbose cli ‘dev’ ]
2 info using npm@5.6.0
3 info using node@v8.11.3
4 verbose config Skipping project config: C:\Users\me/.npmrc. (matches userconfig)
5 verbose run-script [ ‘predev’, ‘dev’, ‘postdev’ ]
6 info lifecycle lite-server@2.4.0~predev: lite-server@2.4.0
7 info lifecycle lite-server@2.4.0~dev: lite-server@2.4.0
8 verbose lifecycle lite-server@2.4.0~dev: unsafe-perm in lifecycle true
9 verbose lifecycle lite-server@2.4.0~dev: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\Users\me\node_modules.bin;C:\Users\me\AppData\Roaming\npm;C:\Program Files\nodejs;C:\oraclexe\app\oracle\product\11.2.0\server\bin;;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Java\jre1.8.0_101\bin;C:\Windows\System32;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files\Microsoft SQL Server\120\DTS\Binn;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\130\DTS\Binn;C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\ManagementStudio;C:\Users\me\AppData\Local\Programs\Python\Python35-32\Scripts;C:\Users\me\AppData\Local\Programs\Python\Python35-32;C:\Program Files (x86)\Brackets\command;C:\Program Files\nodejs;C:\Users\me\AppData\Local\atom\bin;C:\Users\me\AppData\Roaming\npm
10 verbose lifecycle lite-server@2.4.0~dev: CWD: C:\Users\me
11 silly lifecycle lite-server@2.4.0~dev: Args: [ ‘/d /s /c’, ‘lite-server’ ]
12 silly lifecycle lite-server@2.4.0~dev: Returned: code: 1 signal: null
13 info lifecycle lite-server@2.4.0~dev: Failed to exec dev script
14 verbose stack Error: lite-server@2.4.0 dev: lite-server
14 verbose stack Exit status 1
14 verbose stack at EventEmitter. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:285:16)
14 verbose stack at emitTwo (events.js:126:13)
14 verbose stack at EventEmitter.emit (events.js:214:7)
14 verbose stack at ChildProcess. (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
14 verbose stack at emitTwo (events.js:126:13)
14 verbose stack at ChildProcess.emit (events.js:214:7)
14 verbose stack at maybeClose (internal/child_process.js:925:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
15 verbose pkgid lite-server@2.4.0
16 verbose cwd C:\Users\me
17 verbose Windows_NT 6.1.7601
18 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “run” “dev”
19 verbose node v8.11.3
20 verbose npm v5.6.0
21 error code ELIFECYCLE
22 error errno 1
23 error lite-server@2.4.0 dev: lite-server
23 error Exit status 1
24 error Failed at the lite-server@2.4.0 dev script.
24 error This is probably not a problem with npm. There is likely additional logging output above.
25 verbose exit [ 1, true ]


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.