Release: npm@6.9.0-next.0

A new pre-release of the npm cli has been tagged! You can install it with npm i -g npm@next or try it out with npx npm@next …

Pre-releases are promoted to latest after about a week if no serious issues stop them. Try it out, tell us what you think! :thinking:

latest: 6.8.0
next: 6.9.0-next.0

This release includes EXCITING NEW FEATURES, such as time traveling installs and dependency aliases!

FEATURES

BUGFIXES

  • cf09fbaed #153 Set modified to undefined in npm view when time is not available. This fixes a bug where npm view would crash on certain third-party registries. (@simonua)
  • 774fc26ee #154 Print out tar version in install.sh only when the flag is supported not all the tar implementations support --version flag. This allows the install script to work in OpenBSD, for example. (@agudulin)
  • 863baff11 #158 Fix typo in error message for npm stars. (@phihag)
  • a805a95ad npm.community#4227 Strip version info from pkg on E404. This improves the error messaging format. (@larsgw)

DOCS

DEPENDENCIES

2 Likes

Nice, didn’t realize aliases would be here already!

2 Likes

exciting to see aliases!

2 Likes

The --before flag is super awesome!
In the past I already wished for this to be included in other package managers (like apt) because it just makes sense to have it!

2 Likes

Notice: These forums have been archived