npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Release: npm@6.6.0-next.1

A new pre-release of the npm cli has been tagged! You can install it with npm i -g npm@next or try it out with npx npm@next …

Prereleases are promoted to latest after about a week if no serious issues stop them. Try it out, tell us what you think! :dancer:

latest: 6.5.0
next: 6.6.0-next.1

REFACTORING OUT npm-REGISTRY-CLIENT

Today is an auspicious day! This release marks the end of a massive internal refactor to npm that means we finally got rid of the legacy npm-registry-client in favor of the shiny, new, window.fetch -like npm-registry-fetch .

Now, the installer had already done most of this work with the release of npm@5 , but it turns out every other command still used the legacy client. This release updates all of those commands to use the new client, and while we’re at it, adds a few extra goodies:

There’s too many commits to list all of them here, so check out the PR if you’re curious about details:

NEW FEATURES

BUGFIXES

DOCS

DEPENDENCIES

TESTING

MISCELLANEOUS