Release: npm@6.4.1-next.0

release
prerelease

(Kat Marchán) #1

A new prerelease of the npm cli has been tagged!

You can install it with npm i -g npm@next or try it out with npx npm@next …

Prereleases are promoted to latest after a week if no serious issues stop them. Please give it a whirl and tell us what you think! And of course, please report any bugs in #bugs so we can get the release all prettied up if needed~ :nail_care:

latest: 6.4.0
next: 6.4.1-next.0

BUGFIXES

  • 4bd40f543 #42 Prevent blowing up on malformed responses from the npm audit endpoint, such as with third-party registries. (@framp)
  • 0e576f0aa #46 Fix NO_PROXY support by renaming npm-side config to --noproxy. The environment variable should still work. (@SneakyFish5)
  • d8e811d6a #33 Disable update-notifier checks when a CI environment is detected. (@Sibiraj-S)
  • 1bc5b8cea #47 Fix issue where postpack scripts would break if pack was used with --dry-run. (@larsgw)

DEPENDENCY BUMPS

DOCUMENTATION


(Kat Marchán) #2