prompt_git:12: pipe failed: too many open files in system

What I Wanted to Do

After updating Ember CLI, I ran npm audit fix to try and resolve errors.

What Happened Instead

npm WARN deprecated du@0.1.0: no longer maintained
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

fsevents@1.2.7 install /Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents
node install

node-pre-gyp ERR! UNCAUGHT EXCEPTION
node-pre-gyp ERR! stack Error: Cannot find module ‘needle’
node-pre-gyp ERR! stack at Function.Module._resolveFilename (module.js:470:15)
node-pre-gyp ERR! stack at Function.Module._load (module.js:418:25)
node-pre-gyp ERR! stack at Module.require (module.js:498:17)
node-pre-gyp ERR! stack at require (internal/module.js:20:19)
node-pre-gyp ERR! stack at Object. (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/lib/install.js:32:19)
node-pre-gyp ERR! stack at Module._compile (module.js:571:32)
node-pre-gyp ERR! stack at Object.Module._extensions…js (module.js:580:10)
node-pre-gyp ERR! stack at Module.load (module.js:488:32)
node-pre-gyp ERR! stack at tryModuleLoad (module.js:447:12)
node-pre-gyp ERR! stack at Function.Module._load (module.js:439:3)
node-pre-gyp ERR! System Darwin 18.2.0
node-pre-gyp ERR! command “/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/node/bin/node” “/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp” “install” “–fallback-to-build”
/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:120
log.error(‘cwd’, process.cwd());
^

Error: ENFILE: file table overflow, uv_cwd
at errorMessage (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:120:28)
at issueMessage (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:126:3)
at process. (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:111:3)
at emitOne (events.js:96:13)
at process.emit (events.js:191:7)
at process._fatalException (bootstrap_node.js:304:26)
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community
prompt_git:12: pipe failed: too many open files in system

Reproduction Steps

Details

I was getting error that (LTS) Node 10.15.1 was not supported in my current environment. I was attempting to install Node 7, which appears to be the latest version of Node that NPM can handle. Also, to move away from Bower, I was attempting to install yarn which gave issue as well.

npm WARN deprecated du@0.1.0: no longer maintained
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

fsevents@1.2.7 install /Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents
node install

node-pre-gyp ERR! UNCAUGHT EXCEPTION
node-pre-gyp ERR! stack Error: Cannot find module ‘needle’
node-pre-gyp ERR! stack at Function.Module._resolveFilename (module.js:470:15)
node-pre-gyp ERR! stack at Function.Module._load (module.js:418:25)
node-pre-gyp ERR! stack at Module.require (module.js:498:17)
node-pre-gyp ERR! stack at require (internal/module.js:20:19)
node-pre-gyp ERR! stack at Object. (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/lib/install.js:32:19)
node-pre-gyp ERR! stack at Module._compile (module.js:571:32)
node-pre-gyp ERR! stack at Object.Module._extensions…js (module.js:580:10)
node-pre-gyp ERR! stack at Module.load (module.js:488:32)
node-pre-gyp ERR! stack at tryModuleLoad (module.js:447:12)
node-pre-gyp ERR! stack at Function.Module._load (module.js:439:3)
node-pre-gyp ERR! System Darwin 18.2.0
node-pre-gyp ERR! command “/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/node/bin/node” “/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp” “install” “–fallback-to-build”
/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:120
log.error(‘cwd’, process.cwd());
^

Error: ENFILE: file table overflow, uv_cwd
at errorMessage (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:120:28)
at issueMessage (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:126:3)
at process. (/Users/chrismcneese/Projects/JacobsFF-ember/JacobsFF-ember/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp:111:3)
at emitOne (events.js:96:13)
at process.emit (events.js:191:7)
at process._fatalException (bootstrap_node.js:304:26)
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community
prompt_git:12: pipe failed: too many open files in system

Platform Info

$ npm --versions
6.4.1
<!-- paste output here -->
$ node -p process.platform
v10.15.1
<!-- paste output here -->

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.