npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

problem getting package to run in angular-cli

I’m totally new to this so apologies…

I want to run a project which says:

This project was generated with angular-cli version 1.0.0-beta.26.

It is a few years old. I’ve installed angular-cli and the first thing that happened when I tried “ng serve” is the error:

The serve command requires to be run in an Angular project, but a project definition could not be found.

Then I read somewhere that there could be a version problem (I believe I’ve installed the latest version of angular which is 7?) and to try “ng update.”

I got the error:

Could not find a package.json. Are you in a Node project?

I noticed that the package.json in the root directory is prefixed with the project name, so I tried making a copy of the file simply named package.json.

Running ng update again, the following error:

An unexpected error happened; package piano has no version null.

Now, this seems to be progress, in that the contents of package.json were getting processed. And there is a package called piano included in this project. But given how little I understand what I am doing, I am kind of stumped as to how to proceed. If anyone can suggest how to approach getting this project to run, I would greatly appreciate it!

Hi @dssilver! I moved your topic to #javascript since your question is about a package rather than about npm. You will hopefully get an answer here, but might get an answer sooner by asking in an angular forum. Good luck!