premature error during npm install


(Billy Chan) #1

Hi there i got strange premature error when running npm install on macos bash 3.2. Although using yarn install is OK but i still wish to find out the root cause or it, here is the detailed error:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/Cellar/node/11.2.0/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'install' ]
2 info using npm@6.4.1
3 info using node@v11.2.0
4 verbose npm-session eaa48ea4a906a178
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall ODO-Official@0.0.0
7 info lifecycle ODO-Official@0.0.0~preinstall: ODO-Official@0.0.0
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 1537ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 11ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 432ms
16 silly install loadAllDepsIntoIdealTree
17 silly removeObsoleteDep removing @angular/animations@7.0.4 from the tree as its been replaced by a newer version or is no longer required
18 silly removeObsoleteDep removing @angular/common@7.0.4 from the tree as its been replaced by a newer version or is no longer required
19 silly removeObsoleteDep removing @angular/compiler@7.0.4 from the tree as its been replaced by a newer version or is no longer required
20 silly removeObsoleteDep removing @angular/core@7.0.4 from the tree as its been replaced by a newer version or is no longer required
21 silly removeObsoleteDep removing @angular/forms@7.0.4 from the tree as its been replaced by a newer version or is no longer required
22 silly removeObsoleteDep removing @angular/http@7.0.4 from the tree as its been replaced by a newer version or is no longer required
23 silly removeObsoleteDep removing @angular/platform-browser@7.0.4 from the tree as its been replaced by a newer version or is no longer required
24 silly removeObsoleteDep removing @angular/platform-browser-dynamic@7.0.4 from the tree as its been replaced by a newer version or is no longer required
25 silly removeObsoleteDep removing @angular/router@7.0.4 from the tree as its been replaced by a newer version or is no longer required
26 silly removeObsoleteDep removing @ngx-translate/core@11.0.1 from the tree as its been replaced by a newer version or is no longer required
27 silly removeObsoleteDep removing @ngx-translate/http-loader@4.0.0 from the tree as its been replaced by a newer version or is no longer required
28 silly removeObsoleteDep removing animate.css@3.7.0 from the tree as its been replaced by a newer version or is no longer required
29 silly removeObsoleteDep removing bootstrap@3.3.7 from the tree as its been replaced by a newer version or is no longer required
30 silly removeObsoleteDep removing core-js@2.5.7 from the tree as its been replaced by a newer version or is no longer required
31 silly removeObsoleteDep removing font-awesome@4.7.0 from the tree as its been replaced by a newer version or is no longer required
32 silly removeObsoleteDep removing jquery@2.1.1 from the tree as its been replaced by a newer version or is no longer required
33 silly removeObsoleteDep removing rxjs@6.3.3 from the tree as its been replaced by a newer version or is no longer required
34 silly removeObsoleteDep removing slick-carousel@1.8.0 from the tree as its been replaced by a newer version or is no longer required
35 silly removeObsoleteDep removing sweetalert2@7.29.1 from the tree as its been replaced by a newer version or is no longer required
36 silly removeObsoleteDep removing wowjs@1.1.3 from the tree as its been replaced by a newer version or is no longer required
37 silly removeObsoleteDep removing zone.js@0.8.26 from the tree as its been replaced by a newer version or is no longer required
38 http fetch GET 304 https://registry.npmjs.org/@angular%2fcompiler 153ms (from cache)
39 http fetch GET 304 https://registry.npmjs.org/@angular%2fcommon 157ms (from cache)
40 http fetch GET 304 https://registry.npmjs.org/@angular%2fhttp 157ms (from cache)
41 http fetch GET 304 https://registry.npmjs.org/@angular%2fanimations 164ms (from cache)
42 silly pacote version manifest for @angular/compiler@7.0.4 fetched in 161ms
43 silly resolveWithNewModule @angular/compiler@7.0.4 checking installable status
44 http fetch GET 304 https://registry.npmjs.org/@angular%2frouter 162ms (from cache)
45 http fetch GET 304 https://registry.npmjs.org/@angular%2fplatform-browser 165ms (from cache)
46 http fetch GET 304 https://registry.npmjs.org/@angular%2fplatform-browser-dynamic 166ms (from cache)
47 silly pacote version manifest for @angular/common@7.0.4 fetched in 172ms
48 silly resolveWithNewModule @angular/common@7.0.4 checking installable status
49 silly pacote version manifest for @angular/http@7.0.4 fetched in 172ms
50 silly resolveWithNewModule @angular/http@7.0.4 checking installable status
51 silly pacote version manifest for @angular/animations@7.0.4 fetched in 187ms
52 silly resolveWithNewModule @angular/animations@7.0.4 checking installable status
53 silly pacote version manifest for @angular/platform-browser@7.0.4 fetched in 185ms
54 silly resolveWithNewModule @angular/platform-browser@7.0.4 checking installable status
55 silly pacote version manifest for @angular/router@7.0.4 fetched in 186ms
56 silly resolveWithNewModule @angular/router@7.0.4 checking installable status
57 silly pacote version manifest for @angular/platform-browser-dynamic@7.0.4 fetched in 188ms
58 silly resolveWithNewModule @angular/platform-browser-dynamic@7.0.4 checking installable status
59 http fetch GET 304 https://registry.npmjs.org/@angular%2fcore 207ms (from cache)
60 silly pacote version manifest for @angular/core@7.0.4 fetched in 211ms
61 silly resolveWithNewModule @angular/core@7.0.4 checking installable status
62 http fetch GET 304 https://registry.npmjs.org/animate.css 44ms (from cache)
63 silly pacote version manifest for animate.css@3.7.0 fetched in 46ms
64 silly resolveWithNewModule animate.css@3.7.0 checking installable status
65 http fetch GET 304 https://registry.npmjs.org/font-awesome 37ms (from cache)
66 silly pacote version manifest for font-awesome@4.7.0 fetched in 38ms
67 silly resolveWithNewModule font-awesome@4.7.0 checking installable status
68 http fetch GET 304 https://registry.npmjs.org/@ngx-translate%2fcore 242ms (from cache)
69 silly pacote version manifest for @ngx-translate/core@11.0.1 fetched in 246ms
70 silly resolveWithNewModule @ngx-translate/core@11.0.1 checking installable status
71 http fetch GET 304 https://registry.npmjs.org/bootstrap 75ms (from cache)
72 silly pacote version manifest for bootstrap@3.3.7 fetched in 79ms
73 silly resolveWithNewModule bootstrap@3.3.7 checking installable status
74 http fetch GET 304 https://registry.npmjs.org/core-js 66ms (from cache)
75 silly pacote version manifest for core-js@2.5.7 fetched in 69ms
76 silly resolveWithNewModule core-js@2.5.7 checking installable status
77 http fetch GET 304 https://registry.npmjs.org/slick-carousel 33ms (from cache)
78 silly pacote version manifest for slick-carousel@1.8.0 fetched in 34ms
79 silly resolveWithNewModule slick-carousel@1.8.0 checking installable status
80 http fetch GET 304 https://registry.npmjs.org/rxjs 46ms (from cache)
81 silly pacote version manifest for rxjs@6.3.3 fetched in 51ms
82 silly resolveWithNewModule rxjs@6.3.3 checking installable status
83 http fetch GET 304 https://registry.npmjs.org/wowjs 30ms (from cache)
84 http fetch GET 304 https://registry.npmjs.org/jquery 71ms (from cache)
85 silly pacote version manifest for wowjs@1.1.3 fetched in 32ms
86 silly resolveWithNewModule wowjs@1.1.3 checking installable status
87 http fetch GET 304 https://registry.npmjs.org/zone.js 29ms (from cache)
88 silly pacote version manifest for jquery@2.1.1 fetched in 75ms
89 silly resolveWithNewModule jquery@2.1.1 checking installable status
90 silly pacote version manifest for zone.js@0.8.26 fetched in 32ms
91 silly resolveWithNewModule zone.js@0.8.26 checking installable status
92 http fetch GET 304 https://registry.npmjs.org/sweetalert2 43ms (from cache)
93 silly pacote version manifest for sweetalert2@7.29.1 fetched in 50ms
94 silly resolveWithNewModule sweetalert2@7.29.1 checking installable status
95 http fetch GET 304 https://registry.npmjs.org/@ngx-translate%2fhttp-loader 149ms (from cache)
96 silly pacote version manifest for @ngx-translate/http-loader@4.0.0 fetched in 150ms
97 silly resolveWithNewModule @ngx-translate/http-loader@4.0.0 checking installable status
98 silly fetchPackageMetaData error for circlos@git+https://github.com/jamalhassouni/circlos.git premature close
99 http fetch GET 409 https://registry.npmjs.org/@angular%2fforms 5112ms
100 silly fetchPackageMetaData error for @angular/forms@7.0.4 409 Conflict: @angular/forms@7.0.4
101 silly fetchPackageMetaData error for jQuery-Validation-Engine@git+https://github.com/posabsolute/jQuery-Validation-Engine.git premature close
102 timing stage:rollbackFailedOptional Completed in 0ms
103 timing stage:runTopLevelLifecycles Completed in 11080ms
104 silly saveTree ODO-Official@0.0.0
104 silly saveTree ├─┬ @angular-devkit/build-angular@0.10.6
104 silly saveTree │ ├─┬ @angular-devkit/architect@0.10.6
104 silly saveTree │ │ ├─┬ @angular-devkit/core@7.0.6
104 silly saveTree │ │ │ ├─┬ ajv@6.5.3
104 silly saveTree │ │ │ │ ├── fast-deep-equal@2.0.1
.
.
.
.
.
.
.
.
104 silly saveTree │ └── tsutils@2.29.0
104 silly saveTree ├── typescript@3.1.6
104 silly saveTree ├── wowjs@1.1.3
104 silly saveTree └── zone.js@0.8.26
105 verbose stack Error: premature close
105 verbose stack     at PassThrough.onclose (/usr/local/lib/node_modules/npm/node_modules/end-of-stream/index.js:47:67)
105 verbose stack     at PassThrough.emit (events.js:187:15)
105 verbose stack     at emitCloseNT (internal/streams/destroy.js:59:8)
105 verbose stack     at process.internalTickCallback (internal/process/next_tick.js:72:19)
106 verbose cwd /Users/billychan/Projects/ODO-Official
107 verbose Darwin 18.2.0
108 verbose argv "/usr/local/Cellar/node/11.2.0/bin/node" "/usr/local/bin/npm" "install"
109 verbose node v11.2.0
110 verbose npm  v6.4.1
111 error premature close
112 verbose exit [ 1, true ]

(system) #2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.