postupdate hook does not work


(Roaders) #1

What I Wanted to Do

add a postupdate script

What Happened Instead

nothing - the hook did not fire

Reproduction Steps

“postupdate”: “npm run someScript”

Details

I want a postupdate hook that will verify various things - for example that peer and deve dependency versions are in line and to ensure that tildes version ranges have not been replaces with carats (a different bug).
It doesn’t really matter WHAT I want to do - the fact that I can’t is the bug. Pre and Post hooks seems to be supported on every other command, why not here.

Platform Info

$ npm --versions
5