Package version endpoint fails on scoped package

Hello,

I was trying to get latest packave version from npm registry and read this documentation: https://github.com/npm/registry/blob/master/docs/REGISTRY-API.md#getpackageversion

I was receiving 401 unauthorized from npm registry. I assumed I was doing something wrong but after hours of research it appears itโ€™s a known behaviour (https://github.com/npm/registry-issue-archive/issues/34)

Could you update npm documentation (https://github.com/npm/registry/blob/master/docs/REGISTRY-API.md#getpackageversion) to be explicit about this ?

Thanks :)