nvm is not compatible with the "npm_config_prefix", exit status 11


(Scott Barret) #1

Hi, i know this could be borderline on not being an NPM issue. However i’m stumped and this is really becoming a pain. About 3 weeks after having some issues with installing modules globally requiring me to use sudo all the time i removed node/npm and installed nvm to use this as node downloader/manager. Have had troubles since with this error message nvm is not compatible with the "npm_config_prefix" environment variable: currently set to "/Users/scottbarrett/.nvm/versions/node/v9.8.0" Rununset npm_config_prefixto unset it.

I run this command and nothing happens, i’ve raised the issue over at nvm github (https://github.com/creationix/nvm/issues/1873#issuecomment-410425725) and everything seems to look ok but just can’t get rid of this error. When i run scripted npm commands that only contain a single action like executing a shell script it will work fine, however if a command equates to something like restore-db: bash doThis.sh && npm test-db-connection it will fail with the exit status 11 and bring up the config prefix error.

Has anyone encountered this kind of issue before?


(Kat Marchán) #2

I think this is one for @ljharb :sweat_smile:. No, it’s not really an npm issue.


(Jordan Harband) #3

Thanks, indeed it is; the linked github issue is the best place to work it through.


(system) #4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.