npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm stuck during package installation

What I Wanted to Do

I want to install a package using npm in a virtualbox installation of Synology (Linux x64)

What Happened Instead

the process is stucked on readGlobalPackageData:

./npm install -g npm -ddd

npm info it worked if it ends with ok
npm verb cli [ '/volume1/@appstore/Node.js_v8/usr/local/bin/node',
npm verb cli   '/root/node-v10.15.1-linux-x64/bin/npm',
npm verb cli   'install',
npm verb cli   '-g',
npm verb cli   'npm',
npm verb cli   '-ddd' ]
npm info using npm@6.4.1
npm info using node@v8.9.4
npm verb npm-session 0db8c5777e2c4717
npm sill install loadCurrentTree
npm sill install readGlobalPackageData

Any package i’ve tried were stuck in the exact same step.

I have tried two installation of node. the packaged one v8.9.4 with npm 5.6.0
and the lastest lts one: v10.15.1 with npm 6.4.1

I have no proxy at all.
if you have any idea on what to try?

Reproduction Steps

To build the VM i follow the step described here and here

Then i have installed nodejs v8 package from here:

First I have a problem with https so i set these two options and npm ping work fine after that.

npm config set registry
npm config set strict-ssl false

Platform Info

uname -a

Linux DEV 3.10.102 #15047 SMP Thu Feb 23 02:24:19 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs
$ npm --versions
{ npm: '5.6.0',
  ares: '1.10.1-DEV',
  cldr: '31.0.1',
  http_parser: '2.7.0',
  icu: '59.1',
  modules: '57',
  nghttp2: '1.25.0',
  node: '8.9.4',
  openssl: '1.0.2k-fips',
  tz: '2017b',
  unicode: '9.0',
  uv: '1.15.0',
  v8: '6.1.534.50',
  zlib: '1.2.8' }
$ node -p process.platform