npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm search and npm website search issues

Having some problems with npm search both in the terminal and on the website. I’ve filled in the bug submission template (see below).

Yesterday I updated several packages and published a new one. The updated packages took a lot longer than usual for their version to become available for download (several hours). Today, almost 24 hours later, the new package @unleashit/recursive-data-lister still can not be found either via npm search in a terminal or by searching on the website. It can however be installed with npm i @unleashit/recursive-data-lister. I’ve verified that all the metadata is in its package.json. I’ve also tried bumping the version and republishing, but that still hasn’t done the trick.

Another (much more minor) issue is that some of the metadata from two of my other packages isn’t showing up in the type ahead of the website’s search. For example, when I enter just @unleashit, all of my packages (except the new one) are listed, but there is no description or version number for two of them (@unleashit/async-handler and @unleashit/common).

Thanks for your help!

What I Wanted to Do

npm search [my-package] should find the package. It doesn’t (but it can be installed).

What Happened Instead

Nothing, it’s not listed in the search results. See above for more info.

Reproduction Steps

npm search @unleashit/recursive-data-lister

Nothing found, but you can npm install @unleashit/recursive-data-lister and it works.

The package also can’t be found on the npm website.

Please seeabove for other minor issues with search results.


Everything needed saying has been said.

Platform Info

$ npm --versions
{ test: '1.0.0',
  npm: '6.7.0',
  ares: '1.15.0',
  brotli: '1.0.7',
  cldr: '34.0',
  http_parser: '2.8.0',
  icu: '63.1',
  llhttp: '1.1.1',
  modules: '67',
  napi: '4',
  nghttp2: '1.34.0',
  node: '11.12.0',
  openssl: '1.1.1b',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.26.0',
  v8: '',
  zlib: '1.2.11' }
$ node -p process.platform

It’s working now. Interestingly, in the time I took to file the bug it became available. But note that it still wasn’t showing up in the search as of 15 mins ago, which is almost 20 hours after publishing.

I’m having a similar problem. I published dc-mar 48 hours ago, and it’s still not showing up in search results, though it can be installed.

It finally started showing up after a week.

I figured out that my second problem (some stats missing in the typeahead) is as designed. But yeah, it seems like some submissions are getting flagged or delayed.

Website search issues occur due to internal server issue and we can come to know about it from