npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm publish to private TFS feed fails

I facing a issue where npm publish fails on only my machine. I’m trying to publish to a private TFS feed.

Steps I’ve take so far are to clear the cache, reinstalled node & npm, tried different version of npm from 4,5,6, and delete any npm_cache, npm & temp files

I’ve followed the guide on how to setup this up and I’m able to publish on other developers machines

The issue has been discussed, but doesnt seem to help me as the resolution is to use npm adduser or you can probably use npm login which TFS doesnt use. issue

error log:

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Users\\jesse.lay\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'publish' ]
2 info using npm@5.6.0
3 info using node@v8.12.0
4 verbose npm-session 6c6eea6ed8ab5565
5 verbose publish [ '.' ]
6 info lifecycle versasuite-clock@0.1.0~prepublish: versasuite-clock@0.1.0
7 info lifecycle versasuite-clock@0.1.0~prepare: versasuite-clock@0.1.0
8 info lifecycle versasuite-clock@0.1.0~prepublishOnly: versasuite-clock@0.1.0
9 info lifecycle versasuite-clock@0.1.0~prepack: versasuite-clock@0.1.0
10 info lifecycle versasuite-clock@0.1.0~postpack: versasuite-clock@0.1.0
11 verbose getPublishConfig { registry: 'registry=http://dev-v-portal:1337/DefaultCollection/_packaging/packages@Release/npm/registry/always-auth=true' }
12 silly mapToRegistry name versasuite-clock
13 silly mapToRegistry using default registry
14 silly mapToRegistry registry registry=http://dev-v-portal:1337/DefaultCollection/_packaging/packages@Release/npm/registry/always-auth=true
15 silly mapToRegistry data { type: 'tag',
15 silly mapToRegistry   registry: true,
15 silly mapToRegistry   where: undefined,
15 silly mapToRegistry   raw: 'versasuite-clock',
15 silly mapToRegistry   name: 'versasuite-clock',
15 silly mapToRegistry   escapedName: 'versasuite-clock',
15 silly mapToRegistry   scope: undefined,
15 silly mapToRegistry   rawSpec: '',
15 silly mapToRegistry   saveSpec: null,
15 silly mapToRegistry   fetchSpec: 'latest',
15 silly mapToRegistry   gitRange: undefined,
15 silly mapToRegistry   gitCommittish: undefined,
15 silly mapToRegistry   hosted: undefined }
16 silly mapToRegistry uri registry=http://dev-v-portal:1337/DefaultCollection/_packaging/packages@Release/npm/registry/always-auth=true/versasuite-clock
17 verbose publish registryBase registry=http://dev-v-portal:1337/DefaultCollection/_packaging/packages@Release/npm/registry/always-auth=true/
18 silly publish uploading C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz
19 verbose stack Error: EPERM: operation not permitted, unlink 'C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz'
20 verbose cwd C:\Users\jesse.lay\Desktop\Versa-Template\VersaSuite.Packages\Clock
21 verbose Windows_NT 10.0.17134
22 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\jesse.lay\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "publish"
23 verbose node v8.12.0
24 verbose npm  v5.6.0
25 error path C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz
26 error code EPERM
27 error errno -4048
28 error syscall unlink
29 error Error: EPERM: operation not permitted, unlink 'C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz'
29 error  { Error: EPERM: operation not permitted, unlink 'C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz'
29 error   cause:
29 error    { Error: EPERM: operation not permitted, unlink 'C:\Users\jesse.lay\AppData\Local\Temp\npm-8440-cb2c87bb\tmp\fromDir-1f476a6a\package.tgz'
29 error      errno: -4048,
29 error      code: 'EPERM',
29 error      syscall: 'unlink',
29 error      path: 'C:\\Users\\jesse.lay\\AppData\\Local\\Temp\\npm-8440-cb2c87bb\\tmp\\fromDir-1f476a6a\\package.tgz' },
29 error   isOperational: true,
29 error   stack: 'Error: EPERM: operation not permitted, unlink \'C:\\Users\\jesse.lay\\AppData\\Local\\Temp\\npm-8440-cb2c87bb\\tmp\\fromDir-1f476a6a\\package.tgz\'',
29 error   errno: -4048,
29 error   code: 'EPERM',
29 error   syscall: 'unlink',
29 error   path: 'C:\\Users\\jesse.lay\\AppData\\Local\\Temp\\npm-8440-cb2c87bb\\tmp\\fromDir-1f476a6a\\package.tgz' }
30 error Please try running this command again as root/Administrator.
31 verbose exit [ -4048, true ]

I was using LF line ending changed to CRLF and boom it worked