"Npm publish" hangs and never finishes

website
registry
priority:medium
triaged

(Christopher) #1

What I Wanted to Do

I was trying to publish a package to npmjs.

What Happened Instead

I ran npm publish --tag=dev in my terminal and it sits there and never does anything nor does the progress bar change.

Reproduction Steps

Run npm publish --tag=dev

Details

No logfile generated.

Platform Info

$ npm --versions
{ 'ids-enterprise': '4.10.0-dev.20180806',
  npm: '5.6.0',
  ares: '1.14.0',
  cldr: '33.0',
  http_parser: '2.8.0',
  icu: '61.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.29.0',
  node: '10.1.0',
  openssl: '1.1.0h',
  tz: '2018c',
  unicode: '10.0',
  uv: '1.20.2',
  v8: '6.6.346.27-node.6',
  zlib: '1.2.11' }

$ node -p process.platform
darwin

can't publish new version of package
Publish package shown success but cannot install via npmjs
Publish failing due to 500 registry error
npm publish doesn't work
(Kat Marchán) #2

There’s an active incident for something related to this. Can you check if this works again once the incident resolves and let me know if that fixed it?

https://status.npmjs.org/incidents/m6ysvwmc8k7l


(Christopher) #3

I tested it now to check on things and it worked as it should.


(Bluelovers) #4

i didn’t see here has any answer for fix publish Failed PUT 500


(Kat Marchán) #5

Please check if it’s still occurring to you now. If you can still reproduce it today, please post as such in Publish failing due to 500 registry error and we’ll look into it.