npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

Npm package not removing from the organization

What I Wanted to Do

I tried to uninstall 4 different packages which didn’t give me an error just a warning below:-

  1. NPM WARN using --force I sure hope you know what you are doing.

What Happened Instead

So I searched for the name of the package i apparently uninstalled on npm and i could not find it publicly which i want but it was still available in the organization i am in @kandy-io. i was expecting the packages to be deleted from the organization and every other place on npm using the command below:

  1. npm unpublish @scope/package --force

I even tried to delete the packages under the organization team and it couldn’t not delete. I am currently an admin in the organization.

when i try to republish using the command below

  1. npm publish --access public

i get the ERR output below:

npm ERR! publish Failed PUT 400
npm ERR! code E400
npm ERR! Cannot publish over previously published version “3.3.0”. : @kandy-io/uc-sdk

npm ERR! A complete log of this run can be found in:
npm ERR! /home/circleci/.npm/_logs/2019-03-20T18_12_32_265Z-debug.log
Exited with code 1

this is because that package is still in the organization but i need to republish that version again for the public.


From the documentation:

Even if a package version is unpublished, that specific name and version combination can never be reused. In order to publish the package again, a new version number must be used.

thank you for the reply but just a quick question Me removing it from the public, i just don’t understand why that package is still in the organization, is that how it is?. Also can i use the same name but different version next time

I don’t see it on the @kandy-io organisation page.

Yep, “In order to publish the package again, a new version number must be used”.

So in the organization those packages i deleted are still there, i cant delete them. As shown above
but if i search on npm it is not found

but in the link below:-

it dosen’t show 4 of those packages but it acknowledges there are 7 packages on top.

Right now i want to just remove those four packages from the organization.