npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm outdated -g --depth=0 gives err! Cannot read property 'length' of undefined

As you can see it in the following image, when I run npm outdated -g --depth=0 it returns an error.
How can I fix this?


Ok, I uninstall eslint and reinstall it again. Then it does not give any error.
Thanks.


Thanks for update. A matching issue was reported previously here, and there is a fix coming: 'npm outdated' throw an error (Cannot read property 'length' of undefined)


Landing soon: Release: npm@6.9.1-next.0


Thanks. Updating to npm 6.9.1 fixed the problem. npm i -g npm@next.