npm outdated --> Error: "Not implemented yet"

(Spyshower) #1

What I Wanted to Do

I try check my outdated packages for nodejs with npm outdated.

What Happened Instead

Error:

“Not implemented yet”

Debug log (last lines):

93 http fetch GET 304 https://registry.npmjs.org/@ptomasroos%2Freact-native-multi-slider 2153ms (from cache)
94 silly pacote registry packument for @ptomasroos/react-native-multi-slider@^1.0.0 fetched in 2167ms
95 verbose stack Error: Not implemented yet
95 verbose stack at Object.packument (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/fetchers/remote.js:12:22)
95 verbose stack at Object.Fetcher#packument [as packument] (/usr/local/lib/node_modules/npm/node_modules/genfun/lib/genfun.js:1$
95 verbose stack at packument (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/fetch.js:17:18)
95 verbose stack at pinflight (/usr/local/lib/node_modules/npm/node_modules/pacote/packument.js:23:12)
95 verbose stack at /usr/local/lib/node_modules/npm/node_modules/promise-inflight/inflight.js:29:24
95 verbose stack at Promise._execute (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/debuggability.js:313:9)
95 verbose stack at Promise._resolveFromExecutor (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:48$
95 verbose stack at new Promise (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:79:10)
95 verbose stack at _inflight (/usr/local/lib/node_modules/npm/node_modules/promise-inflight/inflight.js:28:25)
95 verbose stack at /usr/local/lib/node_modules/npm/node_modules/promise-inflight/inflight.js:22:14
95 verbose stack at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)
95 verbose stack at Promise._settlePromiseFromHandler (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise. 95 verbose stack at Promise._settlePromise (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:569:18) 95 verbose stack at Promise._settlePromiseCtx (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:606:1
95 verbose stack at _drainQueueStep (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:142:12)
95 verbose stack at _drainQueue (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:131:9)
96 verbose cwd /Users/Creece/Desktop/AwesomeProject
97 verbose Darwin 18.2.0
98 verbose argv “/usr/local/bin/node” “/usr/local/bin/npm” “outdated”
99 verbose node v10.15.3
100 verbose npm v6.9.1-next.0
101 error Not implemented yet
102 verbose exit [ 1, true ]

Reproduction Steps

Well, I don’t know how I am supposed to reproduce this. It works normally on other projects.

Platform Info

$ npm --versions
{ AwesomeProject: '0.1.0',
  npm: '6.9.1-next.0',
  ares: '1.15.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.15.3',
  openssl: '1.1.0j',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '6.8.275.32-node.51',
  zlib: '1.2.11' }

$ node -p process.platform
darwin

As you can see I am using the latest version of npm (npm@latest). The last stable one didn’t work either.

0 Likes

(Lars Willighagen) #2

Seems to be a duplicate of 6.9.0: npm up: "not implemented yet" (6.8.0 should still work). PR:

0 Likes

(Spyshower) #3

@larsgw I tested 6.8.0 and it works. Out of curiosity, how was I supposed to this install the PR you mentioned?

0 Likes

(Lars Willighagen) #4

You could try to install it, but I intended it more of a way for you to track progress (without me having to post updates everywhere).

0 Likes