npm outdated command does not return current version

I run npm outdated command and the output I get does not show the current version. This only occurs for this specific project, other projects return the output just fine.

Output example:

Package                       Current   Wanted   Latest  Location
append-query                  MISSING    2.1.0    2.1.0  access-management
aws-sdk                       MISSING  2.558.0  2.558.0  access-management

Here’s the package.json :

{
  "name": "access-management",
  "version": "1.0.131",
  "description": "Access management",
  "main": "src/index.js",
  "scripts": {},
  "keywords": [
    "identity",
    "api",
    "users",
    "permissions",
    "roles"
  ],
  "author": "Me",
  "license": "ISC",
  "dependencies": {
    "@authenio/samlify-libxml-xsd": "^1.0.1",
    "append-query": "^2.1.0",
    "aws-sdk": "^2.554.0",
    "base-64": "^0.1.0",
    "bcryptjs": "^2.4.0",
    "bluebird": "^3.7.1",
    "body-parser": "^1.19.0",
    "bunyan": "^1.8.12",
    "cassandra-driver": "^3.6.0",
    "cassandra-schema-setup": "^2.0.1",
    "chance": "^1.1.3",
    "express": "^4.17.1",
    "express-requests-logger": "^1.0.19",
    "express-validator": "^3.1.2",
    "generate-password": "^1.4.2",
    "graceful-shutdown-express": "^2.0.0",
    "jsonwebtoken": "^8.5.1",
    "kafka-node": "^4.1.3",
    "lodash": "^4.17.15",
    "moment": "^2.24.0",
    "path": "^0.12.7",
    "pkginfo": "^0.4.0",
    "prom-client": "^11.5.3",
    "prometheus-api-metrics": "^2.2.3",
    "request": "^2.88.0",
    "request-promise": "^4.2.4",
    "retry-as-promised": "^2.3.2",
    "samlify": "^2.6.1",
    "uuid": "^3.3.3",
    "validator": "^6.2.1",
    "zxcvbn": "^4.4.1"
  },
  "devDependencies": {
    "deflate-js": "^0.2.3",
    "delay": "^4.3.0",
    "eslint": "^6.5.1",
    "eslint-config-standard": "^14.1.0",
    "eslint-plugin-import": "^2.18.2",
    "eslint-plugin-node": "^10.0.0",
    "eslint-plugin-promise": "^4.2.1",
    "eslint-plugin-standard": "^4.0.1",
    "fast-xml-parser": "^3.13.0",
    "immutable": "^3.8.2",
    "mocha": "^6.2.2",
    "mochawesome": "^2.0.2",
    "mockdate": "^2.0.5",
    "node-mocks-http": "^1.8.0",
    "nyc": "^14.1.1",
    "predator": "^3.2.0",
    "proxyquire": "^1.7.11",
    "randomstring": "^1.1.5",
    "require-reload": "^0.2.2",
    "should": "^11.1.2",
    "sinon": "^2.3.7",
    "xml2js": "^0.4.22"
  }
}

Please advise on what can be the cause.

The MISSING usually means it is not currently installed. (When I tried installing using your package.json I hit some unavailable/missing packages, but not those ones. First one was cassandra-driver.)

You can also use npm ls to investigate particular packages which might give you more clues:

npm ls append-query

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.