npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

NPM not finding packages in, on Mac only

I have been working on a Mac now for over a year and had to get back to some Node.js work. As I try to install packages using NPM (e.g. npm install -g apiconnect, npm install @cloudnative/health-connect`)

I get a 404 error while installing dependent packages, stating that the package in Not Found. e.g.

Npm install -g apiconnect

... installs a bunch of packages

npm ERR! 404 Not Found - GET - Not Found

However, using curl it is found with no problem.

I am currently running NPM v6.9.0 and Node v10.13.0.

I have checked my configuration and it looks valid.

npm config get registry


I have tried npm cache clean --force, but get the same issue.

I have also tried changing the registry to use https:// instead of http://

npm config set registry

Same error. Also, the error is not all or nothing. While building my node environment, I installed the Angular CLI, and this installed without a problem.

npm install -g @angular/cli

Finally, I have tried everything with my VPN on and off.

I am at a loss for what to try next.