npm installing of vue

Hi,

ive installed vue.js with:
npm install -g @vue/cli

but vue is not in the path after, i found these files

julius@julius-ThinkPad-T560:~$ find .nvm/ -name ‘vue*’
.nvm/versions/node/v10.11.0/bin/vue
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/bin/vue.js
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/@vue/cli-ui/ui-public/vue-logo.png
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/@vue/cli-ui/ui-public/vue-cli.png
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/@vue/cli-ui/src/vue-apollo.js
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-jscodeshift-adapter
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-template-compiler
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-cli-plugin-apollo
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-cli-plugin-apollo/generator/templates/vue-apollo
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-cli-plugin-apollo/generator/templates/vue-apollo/default/src/vue-apollo.js
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/node_modules/vue-sfc-descriptor-to-string
.nvm/versions/node/v10.11.0/lib/node_modules/@vue/cli/lib/promptModules/vuex.js

julius@julius-ThinkPad-T560:~$ echo $PATH
/home/julius/npm-packages/bin:/home/julius/bin:/home/julius/.local/bin:/home/julius/.pyenv/plugins/pyenv-virtualenvwrapper/shims:/home/julius/.pyenv/libexec:/home/julius/.pyenv/plugins/python-build/bin:/home/julius/.pyenv/plugins/pyenv-virtualenvwrapper/bin:/home/julius/.pyenv/shims:/home/julius/.pyenv/bin:/home/julius/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/julius/.dotnet/tools:/usr/lib/jvm/java-11-oracle/bin:/usr/lib/jvm/java-11-oracle/db/bin

what went wrong?

That may be an issue with how you are using nvm rather than with npm. nvm manages the global npm installs separately for each version of node, and also allows you to switch to using the system version of node. My guess is you installed to (nvm managed) v10.11.0 but your shell is currently using the system version of node.

From: https://github.com/nvm-sh/nvm#usage

And then in any new shell just use the installed version:

 nvm use node

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.