NPM install warnings and errors


(Sentrycs) #1

We got the following warnings:
at npm install - see below. Should we address them or ignore them?
npm WARN @babel/register@7.0.0 requires a peer of @babel/core@^7.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @material-ui/core@1.0.0 requires a peer of react@^16.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN @material-ui/core@1.0.0 requires a peer of react-dom@^16.3.0 but none is installed. You must install peer dependencies yourself.
npm WARN ajv-merge-patch@4.1.0 requires a peer of ajv@>=6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN gulp-stylelint@7.0.0 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN sass-loader@7.0.1 requires a peer of webpack@^3.0.0 || ^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN stylelint-config-recommended@2.1.0 requires a peer of stylelint@^8.3.0 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN stylelint-config-standard@18.2.0 requires a peer of stylelint@^8.3.0 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN The package css-loader is included as both a dev and production dependency.
npm WARN The package eslint-plugin-react is included as both a dev and production dependency.
npm WARN The package eth-keyring-controller is included as both a dev and production dependency.
npm WARN The package file-loader is included as both a dev and production dependency.
npm WARN The package gulp is included as both a dev and production dependency.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
we have looked at the npm-cache log and found these errors:
11 error code ELOCKVERIFY
12 error Errors were found in your package-lock.json, run npm install to fix them.
12 error Invalid: lock file’s eth-keyring-controller@3.3.0 does not satisfy eth-keyring-controller@^3.3.1.
Please advise .


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.