npm install hangs on my network, but works on others


(Abbas Yadollahi) #1

I’m having this issue with npm where I cannot install the packages in my package.json on my home network. I tried countless “fixes” (including modifying the registry to http instead of https, modifying the proxy and https-proxy, using unsafe-perm, installing the packages individually, etc.) but none of them seem to work. I decided to try installing them while connected to my phone’s LTE hotspot and miraculously it worked normally. Now my next issue is, what could be causing this?

When I install on my network, it starts to slow down and then completely stops and hangs (on a random package). After a few tries, I was able to install yarn, and could install my dependencies with it.

Extra info:

  • I tried this on multiple node/npm versions but still hangs
  • Verbose install on npm doesn’t give much information, but usually hangs here [.....] \ extract:rxjs: sill extract rxjs@6.3.3 extracted to /home/abbas/git/abbas-yadollahi/node_modules/.staging/rxjs-36adb757 160099ms
  • My network is fine as far as I know (50/10 up/down and I’m on LAN)

(John Gee) #2

I don’t have any specific advice, but in case you had not seen it there is a troubleshooting guide: Common proxy and networking problems


(Abbas Yadollahi) #3

Thanks, I checked the points but I can connect to https://registry.npmjs.org/ and I’m able to manually download the packages normally. The other points don’t seem to be related to my case.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.