npm install hangs on all Git packages


(Core Paradox) #1

Every time npm runs into a dependency that is in git format (user/repo) or (user/repo#branch) it infinitely hangs. I’ve just started experiencing this today, and have tried multiple node versions, and npm versions. I’ve also tried npm cache clear --force.

I’m on a windows machine running node v10.8.0 and npm

Here’s a log example, it just hangs there until I force close it. Yarn works however.

npm install --loglevel verbose discordjs/discord.js#master
npm info it worked if it ends with ok
npm verb cli [ 'C:\\Program Files\\nodejs\\node.exe',
npm verb cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
npm verb cli   'install',
npm verb cli   '--loglevel',
npm verb cli   'verbose',
npm verb cli   'discordjs/discord.js#master' ]
npm info using npm@6.2.0
npm info using node@v10.8.0
npm verb config Skipping project config: C:\Users\Core/.npmrc. (matches userconfig)
npm verb npm-session 2e286b42d13255e1
npm info lifecycle discord.js@12.0.0-dev~prepack: discord.js@12.0.0-dev
npm info lifecycle discord.js@12.0.0-dev~postpack: discord.js@12.0.0-dev
npm timing stage:loadCurrentTree Completed in 4730ms
npm timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
npm timing stage:loadIdealTree:loadShrinkwrap Completed in 2ms
[..................] / fetchMetadata: sill resolveWithNewModule discord.js@12.0.0-dev checking installable status

Let me know if I can provide any more information.


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.