Npm install from github always fails

What I Wanted to Do

Install "ember-cli-svgstore": "ciena-blueplanet/ember-cli-svgstore#977df1cf58ae43b1d98a591573c3e06947744321",

What Happened Instead

npm ERR! code ENOLOCAL
npm ERR! Could not install from “node_modules/frost-application-components/ember-cli-svgstore@github:ciena-blueplanet/ember-cli-svgstore#977df1cf58ae43b1d98a591573c3e06947744321” as it does not contain a package.json file.

Reproduction Steps

  1. Npm install with ``“ember-cli-svgstore”: “ciena-blueplanet/ember-cli-svgstore#977df1cf58ae43b1d98a591573c3e06947744321”,`
  2. New package-lock.json made
  3. Remove node_modules
  4. npm install
  5. get error

Details

2019-02-27T19_20_29_838Z-debug.log (224.3 KB)

Platform Info

$ npm --versions
{ 'frost-login-ui': '4.0.5',
  npm: '6.8.0',
  ares: '1.14.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.32.0',
  node: '10.7.0',
  openssl: '1.1.0h',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.22.0',
  v8: '6.7.288.49-node.15',
  zlib: '1.2.11' }
$ node -p process.platform
darwin

I was not able to reproduce with:

npm init -y
npm install ciena-blueplanet/ember-cli-svgstore#977df1cf58ae43b1d98a591573c3e06947744321
rm -rf node_modules/
npm install

Your error message includes frost-application-components in the path. I do not have that string anywhere in my project. Perhaps an interaction with another package?

I believe ember-cli-svgstore is a subdependency of frost-application-components (which I can’t find it on npm or GitHub). The problem seems to occur earlier, where npm/pacote tries to fetch

ember-cli-svgstore@file:ember-cli-svgstore@github:ciena-blueplanet/ember-cli-svgstore#977df1cf58ae43b1d98a591573c3e06947744321

In which case the frost-application-components part in the path would be correct, as it would look for a file in that package. However, I’m not sure where that fetch/save spec is coming from in the first place.

@EWhite613 can you share the part of package-lock.json with the ember-cli-svgstore dependency?

I managed to fix it by downgrading to 6.3.0

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.