npm install don't work

cli
triaged

(Ahmed Abd El Razek) #1

What I Wanted to Do

i tried to type npm install to a fresh laravel 5.6 project i tried it from win10 and inux and the same problem shows

What Happened Instead

An error NPM ERR

Reproduction Steps

Details

2018-08-13T15_13_34_743Z-debug.log (331.0 KB)

Platform Info

$ npm --versions
{ npm: '6.3.0',
  ares: '1.14.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.32.0',
  node: '10.8.0',
  openssl: '1.1.0h',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.22.0',
  v8: '6.7.288.49-node.19',
  zlib: '1.2.11' }

$ node -p process.platform
win32

 

(Kat Marchán) #2

This is a support issue. I’ve moved this to #support. This is the relevant part of the npm-debug.log:

2753 verbose stack Error: node-sass@4.5.3 postinstall: `node scripts/build.js`
2753 verbose stack Exit status 1
2753 verbose stack     at EventEmitter.<anonymous> (C:\Users\razek\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\index.js:304:16)
2753 verbose stack     at EventEmitter.emit (events.js:182:13)
2753 verbose stack     at ChildProcess.<anonymous> (C:\Users\razek\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
2753 verbose stack     at ChildProcess.emit (events.js:182:13)
2753 verbose stack     at maybeClose (internal/child_process.js:962:16)
2753 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:249:5)
2754 verbose pkgid node-sass@4.5.3

Unfortunately, run-script output is not included in the debug log, so the user might want to post the run-script output from their terminal for further help.

tl;dr node-sass is failing, and this is probably a node-sass issue.


(Ahmed Abd El Razek) #3

i tried it again but i got a different error

$ npm install
npm WARN at.js@1.5.3 requires a peer of jquery@^1.7.0 but none is installed. You must install peer dependencies yourself.
npm WARN extract-text-webpack-plugin@2.1.2 requires a peer of webpack@^2.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN webpack-dev-middleware@1.10.2 requires a peer of webpack@1 || ^2.1.0-beta || ^2.2.0-rc.0 but none is installed. You must install peer dependencies yourself.
npm WARN webpack-dev-server@2.5.0 requires a peer of webpack@^2.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

audited 16814 packages in 17.997s
found 101 vulnerabilities (44 low, 37 moderate, 19 high, 1 critical)
run npm audit fix to fix them, or npm audit for details


(Kat Marchán) #4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.