npm install does not end with OK nor an error

If this is not the correct place to question this, please accept my apologies and be so kind as to point me to the right direction. I’m new to Git Bash, node.js, npm and gulp. Just trying to keep up with a Wordpress developer course :).

I’m running “npm install --verbose” that uses the 4 files attached (I appended “.log” .to the “.js” files names).
package.json (883,Bytes) gulpfile.js.log (1,6,KB) settings.js.log (623,Bytes) webpack.config.js.log (534,Bytes)
The command “npm install --verbose” returns this log:
npm_install.log (63,5,KB) .

“node_modules” folder is created with “.staging” folder as the only content that seems to have all dependency modules/packages(?).
In my folder “C:\Users\username\AppData\Roaming\npm-cache_locks” an empty file is written with the name staging-0316ed059358b92d.lock.
Also Node.js processes kept running in the Windows Task Manager long after the npm install command ended.

When I run “gulp something”, i get the following error:
internal/modules/cjs/loader.js:638
throw err;
^

Error: Cannot find module ‘webpack’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:690:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object. (C:\xampp\htdocs\testsite\gulp\gulpfile.js:3:11)
at Module._compile (internal/modules/cjs/loader.js:776:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:787:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)

I’m guessing that that error is due to the “npm install” command not ended with “OK”, leaving the installation in the middle with the dependency modules in the “.staging” folder. Problem is that I can’t figure it what when wrong to fix it.

Versions n use are:
$ node --version
v10.16.0

$ npm --version
6.9.0

(don’t really know if the following matters)
$ gulp --version
CLI version: 2.2.0
Local version: Unknown

I’m running behind a company firewall and I set that property already. I run this exactly command at home, inside Oracle VM Virtual Box with Win 10 image and all goes well. Didn’t find out what could be different between the two setups.

Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.