npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm install appium --chromedriver_version won't update driver

Hi there.

I am referring to this documentation: https://appium.io/docs/en/writing-running-appium/web/chromedriver/

My Dev config:

I tried to install a few different versions of ChromeDriver by using npm command (for example: npm install appium --chromedriver_version=“77.0.3865.40”). I also tried to restart Appium server between installations as well. Nothing helps and I still getting same error (see attached logs below). It seems like the ChromeDriver was not updated despite the nmp command and it still running an old version (Driver info: chromedriver=2.46.62840) …

Logs from Appium:

[W3C] Encountered internal error running command: Error: Unable to automate Chrome version because it is too old for this version of Chromedriver.
[W3C] Chrome version on the device: Chrome/76.0.3809.111
[W3C] Visit 'https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/web/chromedriver.md' to troubleshoot the problem.
[W3C] Failed to start Chromedriver session: A new session could not be created. Details: session not created: Chrome version must be between 71 and 75
[W3C]   (Driver info: chromedriver=2.46.628402 (536cd7adbad73a3783fdc2cab92ab2ba7ec361e1),platform=Windows NT 10.0.17763 x86_64)
[W3C]     at Object.wrappedLogger.errorAndThrow (C:\Users\superadmin\AppData\Local\Programs\Appium\resources\app\node_modules\appium\node_modules\appium-support\lib\logging.js:78:13)
[W3C]     at Chromedriver.errorAndThrow [as start] (C:\Users\superadmin\AppData\Local\Programs\Appium\resources\app\node_modules\appium\node_modules\appium-chromedriver\lib\chromedriver.js:441:11)
[HTTP] <-- POST /wd/hub/session 500 5564

I would like to have some help here in order to resolve this issue.

Thanks,

Egor


(You might get an answer here, but because this forum is focused on npm, you might want to ask your question somewhere that targets experts with your package. I have moved your topic to #community:javascript)