NPM freezes on extract array-find@1.0.0


(Daniel Kaplan) #1

What I Wanted to Do

I am running npm install to get the latest modules.

What Happened Instead

It installs some modules, then it gets stuck when it says this:

extract:npm: sill extract array-find@1.0.0

I’ve deleted node_modules, reinstalled npm, deleted my ~/.npm directory, etc. It still freezes on this step.

Reproduction Steps

I’m not a node developer, so I may need some help providing some reproduction steps. Here’s my package-lock.json file: https://gist.github.com/dkaplan-pivotal/1242aa842d59fe0586724e17b1ad4c8c

I’d like to provide an npm-debug.log file, but I can’t find one on my file system.

Details

I’ve tried running with --verbose, but it doesn’t output any information.

Platform Info

$ npm --versions
{ frontend: '0.0.0',
  npm: '6.4.1',
  ares: '1.14.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.12.0',
  openssl: '1.1.0i',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '6.8.275.32-node.35',
  zlib: '1.2.11' }
$ node -p process.platform
darwin

(Daniel Kaplan) #2

I fixed this by deleting the package-lock.json and then reverting it (a good version happened to be committed). I still would like to know why this was freezing on the package-lock.json that I uploaded though.