npm error installing dependencies for https://github.com/ConsenSys/diligence-takehome/ after reinstalling node


(quantumpotato) #1

it asked me to report a bug. npm/npm was closed and npm/cli doesn’t have issues so here it is.

/Users/quantum/.npm/_logs/2018-07-29T02_42_10_182Z-debug.log

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/local/bin/node’,
1 verbose cli ‘/usr/local/bin/npm’,
1 verbose cli ‘install’,
1 verbose cli ‘truffle-hdwallet-provider’ ]
2 info using npm@6.1.0
3 info using node@v10.7.0
4 verbose npm-session b92c546e7472b403
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 timing npm Completed in 497ms
8 error cb() never called!
9 error This is an error with npm itself. Please report this error at:
10 error https://github.com/npm/npm/issues


(quantumpotato) #2

https://github.com/npm/npm/issues/17413 seemingly related as I try to do a regular npm install…


(David Bouman) #3

Likely related to [crash] npm ERR! cb() never called!


(system) #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.