npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm error cb() never called using global package create-react-app

What I Wanted to Do

I was trying to create a react app using create-react-app

What Happened Instead

I got an error message from npm (replaced some of my personal info w _____):

Creating a new React app in /Users//Desktop/__.

Installing packages. This might take a couple of minutes.
Installing react, react-dom, and react-scripts…

Unhandled rejection Error: EACCES: permission denied, open ‘/Users/________/.npm/_cacache/index-v5/cb/f5/5167796b1df601b21f55bcc456b993154cc89759e4da4e7dabdc82aa83ad’

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/_______/.npm/_logs/2019-04-17T21_22_52_712Z-debug.log

Aborting installation.
npm install --save --save-exact --loglevel error react react-dom react-scripts has failed.

Deleting generated file… package.json
Deleting new-app/ from /Users//Desktop/_____

Reproduction Steps

I just globally installed create-react-app and at that time installed the new version of npm. I have never successfully used the package.

Just now I tried:
create-react-app new-app

and got the above error.


2019-04-17T21_22_52_712Z-debug.log (113.1 KB)

Platform Info

$ npm --versions
{ npm: '6.9.0',
  ares: '1.15.0',
  cldr: '33.1',
  http_parser: '2.8.0',
  icu: '62.1',
  modules: '64',
  napi: '3',
  nghttp2: '1.34.0',
  node: '10.15.1',
  openssl: '1.1.0j',
  tz: '2018e',
  unicode: '11.0',
  uv: '1.23.2',
  v8: '',
  zlib: '1.2.11' }
$ node -p process.platform

Ok I ran this and it worked after:
sudo npm cache clean -f