npm ERR! cb() never called! error


(Nenad Bulatovic) #1

I just did: npm install
and I got error:

$ npm install
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://npm.community

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Nenad\AppData\Roaming\npm-cache_logs\2018-09-02T16_06_32_259Z-debug.log

0 info it worked if it ends with ok
1 verbose cli [ ‘C:\nodejs\node.exe’,
1 verbose cli ‘C:\Users\Nenad\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’ ]
2 info using npm@6.4.0
3 info using node@v8.11.4
4 verbose npm-session e59d58174fac1f93
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall angular-quickstart@1.0.0
7 info lifecycle angular-quickstart@1.0.0~preinstall: angular-quickstart@1.0.0
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 24ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 6ms
16 silly install loadAllDepsIntoIdealTree
17 timing npm Completed in 1361ms
18 error cb() never called!
19 error This is an error with npm itself. Please report this error at:
20 error <https://npm.community>

$ npm --versions
{ 'angular-quickstart': '1.0.0',
  npm: '6.4.0',
  ares: '1.10.1-DEV',
  cldr: '32.0',
  http_parser: '2.8.0',
  icu: '60.1',
  modules: '57',
  napi: '3',
  nghttp2: '1.32.0',
  node: '8.11.4',
  openssl: '1.0.2p',
  tz: '2017c',
  unicode: '10.0',
  uv: '1.19.1',
  v8: '6.2.414.54',
  zlib: '1.2.11' }

$ node -p process.platform
win32

(Artem Varaksa) #2

This is probably very related to [crash] npm ERR! cb() never called!.


(Kat Marchán) #3