npm deprecate results in 422 error

Iā€™m trying to deprecate the package vis doing this:
npm deprecate vis "Please consider using https://github.com/visjs"

Sady this results in an 422 error:
npm ERR! code E422
npm ERR! Unprocessable Entity : vis

What am I doing wrong?

2019-07-28T21_03_34_210Z-debug.log (4,9 KB)

Perhaps because the release versions are already deprecated? I note that all of the release versions are showing as deprecated on npmjs: https://www.npmjs.com/package/vis

The only two versions showing (as not deprecated) are versions 4.21.0-EOL and 4.20.1-SNAPSHOT.

I have no idea how this happend but deprecating the two missing version individually did the trick. Thanks!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.