npm Community Forum (Archive)

The npm community forum has been discontinued.

To discuss usage of npm, visit the GitHub Support Community.

npm ci broken when version doesn't exist on npm (but does where resolved)

2019-02-28T21_30_54_194Z-debug.log (428.3 KB)

Npm install gives me this in my package-lock.json

        "ember-hook": {
          "version": "1.4.3",
          "resolved": "git://github.com/EWhite613/ember-hook.git#ea5513312eee70abed4b242435066ea446e12281",
          "dev": true,
          "requires": {
            "ember-cli-babel": "^6.0.0",
            "ember-get-config": "^0.2.0"
          }

When I run npm ci I’ll crash saying it cannot find the version 1.4.3. 1.4.3 doesn’t actually exist, just exists in that branch.

If I manually modify the package-lock.json to npm ci will work as expected (it does this for most other references of ember-hook)

    "ember-hook": {
      "version": "git://github.com/EWhite613/ember-hook.git#ea5513312eee70abed4b242435066ea446e12281",
      "from": "git://github.com/EWhite613/ember-hook.git#ea55133",
      "dev": true,
      "requires": {
        "ember-cli-babel": "^6.0.0",
        "ember-get-config": "^0.2.0"
      }
    },

Using npm 6.4.1. I’ve tried 6.8.0 same issue


Looks like a duplicate of

The fix is more or less known but I was waiting on someone else to make the PR.