npm audit failing with "ELOCKVERIFY" error

npm audit fails with this weird error on my Angular 8 project:

npm ERR! code ELOCKVERIFY
npm ERR! Errors were found in your package-lock.json, run  npm install  to fix them.
npm ERR!     Invalid: lock file's typescript@3.4.5 does not satisfy typescript@^3.4.5, <3.5

It does not quite make sense to me, as 3.4.5 seems to satisfy ^3.4.5, no?

npm install works fine, but does not fix the issue as advertised in the error message.

What should I look at to understand what’s going on?

(Tried to remove node_modules and package-lock.json, but the error persists. Tried to update node and npm, currently using node 12.6.0 and npm 6.10.1).

That comma looks out of place to me. What’s the dependency listed as in package.json?

1 Like

The line in packages.json is:

"typescript": "^3.4.5, <3.5",

Removing the comma here solves the issue! Thanks!

It has been put there by the Angular CLI at some point. I will report this there.