npm anything results in 'segmentation fault (core dumped)'


(SOI Software) #1

Behavior started after upgrading server from Ubuntu 12.04 to 14.04. Started getting nvm error nvm is not compatible with the npm config "prefix" option: currently set to ""

running nvm use --delete-prefix v8.11.4 results in segmentation fault (core dumped) as does any npm config command, as does npm -v or npm install, or anything to do with npm.

I’ve tried completely purging and reinstalling nodejs and npm, both through apt-get and nvm. No luck, always end up in the same place.

I have not been able to find where the supposed “prefix” option is set to “”, as I don’t have a user level .npmrc file, have checked those in .nvm to make sure they don’t have any prefix line, etc etc.

So, basically, can’t find the prefix config option to get rid of it, can’t use npm or nvm to unset it as they just seg fault, can’t rebuild or upgrade or do anything with npm as it seg faults.

Any help is appreciated, thanks.


(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.